Adapt your old web application to PHP 8

2761 readings
2024-01-29
PHP is a basic language in the history of the Internet, and is used by content managers such as WordPress and PrestaShop, among others. In addition, it is widely used for custom web applications. Applications made with PHP 5.4, PHP 5.6 or even PHP 7 now need to be updated to PHP 8.
Image of Adapt your old web...

It is a fairly common situation. Time ago, someone developed for you or your company a web application with PHP, which has barely needed maintenance and has been running for years, becoming a fundamental piece for your activity.

I'm talking about applications that work mainly under PHP 5.6, but it can also be with PHP 5.4, or even earlier. And including more recent applications, made for PHP 7, that, with the appearance of PHP 8, have also become obsolete, especially because hosting imposes using PHP 8.

The problem is delicate, because, especially in the case of versions prior to PHP 7, multiple critical errors will surely arise when trying to run the application under PHP 8. So, the scare is great, because redoing that same application now is going to require too much time and money.

However, you should know that it's possible to review that application to make it compatible with PHP 8, without needing to completely remake it.

Currently, PHP 8.2 is usually set as the target version. It's a matter of tweaking the application so that it does not generate errors running under this target version. However, retouching often includes improvements, such as encapsulating the interaction with the database if it is not already encapsulated (many PHP 5.6 applications use MySql functions directly instead of a class), and change the use of said MySql functions (obsolete) to MySqli or even PDO. Also, sometimes the configuration data is repeated in different files, so it's very convenient to centralize it in a single location.

Expert in upgrading to PHP 8

I have a lot of experience in this type of tasks, and I'm used to applying reverse engineering on web applications made for PHP versions prior to branch 8.

If this is your situation, and you need my help, don't hesitate to write me telling me about the situation. Normally, after taking a look at the files to analyze the application, I will be able to offer you an approximate budget, which will undoubtedly be much cheaper than having to do the same application again.

Contact me now

Next new: Not found

Previous new: 20th Anniversary of my relationship with PHP